• Вопрос без рабочей ссылки на проблему считается риторическим. Без ссылки и скриншота - провокацией!
  • Темы озаглавленные с маленькой буквы или капсом удаляются без предупреждения!

Изменить вид сообщения об ошибке

Macstuff

Форумчанин
#1
Подскажите на основе какого шаблона появляется сообщение "Выберете объект в списке" при попытке добавить товар в корзину без выбранных вариаций.
Woocommerce 2.3.9, из-за одного плагина не могу обновиться на более новую версию.
Пытался найти по переводу, но поиск не находит ни в одном файле этого текста.

Цель привести сообщение из такого вида

к такому
 

Useer72

Опытный
Местный
#2
не знаю как на версии 2.3.9 но в новой версии это
includes/class-wc-frontend-scripts.php
 

Macstuff

Форумчанин
#4
не знаю как на версии 2.3.9 но в новой версии это
includes/class-wc-frontend-scripts.php
А вот и нет, в этом файле касается "выберете опцию", а нужно "Выберете объект в списке"
Удалить - обновится - поставить заново?
Увы плагин написан под заказ и из-за изменения способа вывода цены в 2.4 не обновляем.
 

Useer72

Опытный
Местный
#5
А вот и нет, в этом файле касается "выберете опцию", а нужно "Выберете объект в списке"
Ну это потому, что у вас выскакивает не "дефолтное" окно woo а всплывающая подсказка какого-то плагина. Поэтому надо попробовать поискать не по переводу вуу, а вообще во всех файлах папки language.
Если не поможет, значит там значение так и присвоено по русски, и искать надо это значение в файлах php в папке plugins. Советую Notepad++, меня лично не подводил пока ни разу если что то подобное найти надо
 
Последнее редактирование:
Сверху Снизу