• Вопрос без рабочей ссылки на проблему считается риторическим. Без ссылки и скриншота - провокацией!
  • Темы озаглавленные с маленькой буквы или капсом удаляются без предупреждения!

Villaggio - Итальянская кухня

Image CMS

rikitiki

Специалист
Местный
#21
Сменить логин admin на другое имя, установить плагин Limit Login Attempts и ограничить в нём по ip количество попыток авторизации, установить плагин Lockdown WP Admin и изменить в нём адрес страницы авторизации Wordpress. Правда адрес страницы авторизации Wooconnerce плагин не меняет. Но ломают обычно по первому адресу.
 
Последнее редактирование:

D&B

Администратор
Команда форума
Местный
#22
У всех так, просто не все видят. Установите приличный секюрный плагин и забудьте.
 

Labunsky

Специалист
Местный
#25
Мощные плагины!
Но по совету хост-провайдера:
...мы рекомендуем закрыть возможность входа для сторонних ip в административную панель. Для этого достаточно внести изменения в файл .htaccess:

<Files wp-login.php>
order deny,allow
deny from all
allow from My_IP
</files>

Для получения доступа с Вашего ip необходимо в секции "<Files>" в строке "allow from My_IP" вместо "My_IP" прописать внешний IP-адрес компьютера, с которого производится работа с административной панелью сайта.
Узнать свой IP-адрес можно, например, на сайте http://myip.ru.
конечно этот способ не совсем комфортный, как говорится "с удобствами во дворе ;)" и желателен для статических IP-адресов, но очень прост (для начала).
 

-Vladislav-

Опытный
Местный
#26
Будет полезно счастливым обладателям хостинга nic.ru (ru center) в связке с плагином iThemes Security.
-------
Захожу на сайт, вижу вместо сайта ошибку 500, - в админку тоже не зайти.
Перевел сервер обратно из ручного режима в автоматический (вдруг чего с nginx накосячил, хотя все работало) - не помогло.
iThemes Security был настроен так - если юзеру вздумается ломиться в админку с логином admin - сразу бан.
Открываю .htaccess и вижу таких забаненых ( в данном случае одного), выглядит это так:
Код:
    # Ban Hosts - Security > Settings > Banned Users
    SetEnvIF REMOTE_ADDR "^188\.163\.107\.173$" DenyAccess
    SetEnvIF X-FORWARDED-FOR "^188\.163\.107\.173$" DenyAccess
    SetEnvIF X-CLUSTER-CLIENT-IP "^188\.163\.107\.173$" DenyAccess

    <IfModule mod_authz_core.c>
        <RequireAll>
            Require all granted
            Require not env DenyAccess
            Require not ip 188.163.107.173
        </RequireAll>
    </IfModule>
    <IfModule !mod_authz_core.c>
        Order allow,deny
        Allow from all
        Deny from env=DenyAccess
        Deny from 188.163.107.173
    </IfModule>
Удаляю эту секцию - сайт работает, возвращаю назад, опять падает с 500.
Смотрю логи, вижу:
Код:
/docs/.htaccess: Unknown Authz provider: ip
/docs/.htaccess: Unknown Authz provider: ip, referer: [url]http://villaggio42.ru/[/url]
Выясняется, что что для нормальной работы секции, которую создает iThemes Security для бана, должен быть включен на сервере модуль mod_authz_host, который доставить и подключить я не могу, т.к под рутом на сервер не попасть.
----------
Месяц назад на wordpress.org/support еще один счастливый обладатель хостинга nic.ru поднимал точно такую же проблему, в итоге nic.ru ему ответили - ничем помочь не можем. Такой расклад не устраивает, возможно потормошу представителей в нашем регионе, ибо на форуме nic.ru мне вообще никто не ответил.
----------
В итоге в iThemes Security пришлось отключить бан лист, а пользователя забанил сам через тот же .htaccess.
 
Сверху Снизу