• Вопрос без рабочей ссылки на проблему считается риторическим. Без ссылки и скриншота - провокацией!

Вышел WooCommerce 3.0 “Bionic Butterfly” (описание на русском)

Image CMS

nyrt

Форумчанин
#21
Всем (и в первую очередь Майору КГБ) большое спасибо за помощь! Заработало!!! )))
'yourtheme_setup' - не менял на своё название
 

Palundra

Новичок
#22
всем привет, обновился вместе с темой Flatsome, пока всё вроде в порядке, не хватает перевода. Может переведу сегодня, выложу
Не поделитесь переводом на Flatsome?

На 3.0.1. ru не добавили? Где вообще можно смотреть список изменений по версиям?
 
Последнее редактирование:

nyrt

Форумчанин
#27
Странное дело. Удалил из папки /wp-content/languages/plugins файлы:
woocommerce-admin-ru_RU.mo
woocommerce-admin-ru_RU.po
Но перевод админки WC работает нормально.

Теперь что, перевод и админки и не админки в одном (точнее двух файлах)?
woocommerce-ru_RU.mo
woocommerce-ru_RU.po

Да, "Cart totals" не перевели. Но по сравнению со вчерашним переводом прогресс заметен.
 

Sunman

Новичок
#30
У меня другая проблема. Кто-нибудь пользуется woocommerce product add-ons? Вышла новая версия 2.8.1. Если у кого есть обнова поделитесь, пожалуйста. Старая версия с новым WooCommerce не работает.
 

MKs

Новичок
#33
День добрый!
После перехода на 3.0 в вариативных товарах при выборе варианта не меняется изображение варианта. Остается общее изображение товара. Откатил назад все опять работает. Второй день ищу/читаю как починить, но ничего не нашел. Лайтбоксы новые работают. Тему тоже обновил. Сталкивался кто нибудь? Как починить? В остальном проблем нет.
 

D&B

Администратор
Команда форума
Местный
#34
Проверил у себя - все вариации работают вроде корректно. Теребите автора шаблона если уже все обновили.
 

MKs

Новичок
#35
Понял, спасибо! Тема Kleo 4.2.2 только что обновилась, но ... Пойду авторам напишу
 
#36
Я снова про ЛайтБоксы. Сижу в танке, не понимаю.

"В файле вашей темы function.php копируем этот текст и меняем

add_action( 'after_setup_theme', 'имя вашей темы_setup' );

function имя вашей темы_setup() {
add_theme_support( 'wc-product-gallery-zoom' );
add_theme_support( 'wc-product-gallery-lightbox' );
add_theme_support( 'wc-product-gallery-slider' );
}"


В моем function.php есть:

add_action('after_setup_theme', 'zerif_setup');

function zerif_excerpt_more( $more ) {
return ' <a href="'.get_the_permalink().'" rel="nofollow"><span class="sr-only">' . esc_html__('Read more about ', 'zerif-lite').get_the_title() . '</span>[...]</a>';
}
......................

куда чего и вместо чего добавлять, так и не понял. Пару раз в разных вариантах вставлял с изменением "имя вашей темы"- вылетал сайт.
Проясните, для танкистов, а?
 

evgen06

Новичок
#37
Ну и зря откатывались. Документацию видимо только дураки читают.
Тем у кого перестали работать лайтбоксы решение от разработчиков вот. Нужно в теме включить поддержку новых галерей.

add_action( 'after_setup_theme', 'yourtheme_setup' );

function yourtheme_setup() {
add_theme_support( 'wc-product-gallery-zoom' );
add_theme_support( 'wc-product-gallery-lightbox' );
add_theme_support( 'wc-product-gallery-slider' );
}

Видео новой галереи вот
Спасибо!
 

GerdaLost

Новичок
#38
Добрый день, коллеги! Может кто-то уже столкнулся с такой проблемой после обновления: при выведении вилки цены в вариативном товаре показывает цену варианта, которого нет в наличии. В моем примере у первого товара - вариации за 150р. нет, но сайт её настойчиво включает в вилку цен. Пробовала вариацию удалить и создать заново, не помогает.
 

Вложения

Mixon14

Форумчанин
#39
Ну и зря откатывались. Документацию видимо только дураки читают.
Тем у кого перестали работать лайтбоксы решение от разработчиков вот. Нужно в теме включить поддержку новых галерей.

add_action( 'after_setup_theme', 'yourtheme_setup' );

function yourtheme_setup() {
add_theme_support( 'wc-product-gallery-zoom' );
add_theme_support( 'wc-product-gallery-lightbox' );
add_theme_support( 'wc-product-gallery-slider' );
}

Видео новой галереи вот

Помогите разобраться. Установил себе код. Но изображение главной картинки как-то странно отображается. Во-первых, она как-то по краям обрезана получается, а во-вторых, листая фотки галереи слева остаётся кусочек фото предыдущего слайда.

На демонстрационном видео такого нет. Там картинка чётко в рамке находится.

В чём может быть дело?
 
#40
Помогите разобраться. Установил себе код. Но изображение главной картинки как-то странно отображается. Во-первых, она как-то по краям обрезана получается, а во-вторых, листая фотки галереи слева остаётся кусочек фото предыдущего слайда.

На демонстрационном видео такого нет. Там картинка чётко в рамке находится.

В чём может быть дело?
Очевидно дело в размерах самих изображений. Нужно смотреть конкретно ваш сайт и разбираться.