Введите часть искомого слова, названия или фразы...
↑ ↓
  1. Новые темы озаглавленные с маленькой буквы - удаляются без предупреждения!
  2. Вопрос без рабочей ссылки на проблему считается риторическим. Без ссылки и скриншота - провокацией!

Решено Ошибка javascript

Тема в разделе "Вопросы, советы и доработки.", создана пользователем Ria, 27 сен 2016.

  1. Ria

    Ria

    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    6
    Помогите понять как исправить:
    есть 3 блока на сайте (каждый использует js)

    -Картинка в хедере (в теме)
    -Калькулятор
    -FAQ (плагин HTML5 Responsive FAQ)

    Все работало до добавления калькулятора

    В блоке калькулятора подключена js
    Код:
    <script src="http://ajax.googleapis.com/ajax/libs/jquery/1.4/jquery.min.js"></script>
    Когда она подключается, перестають работать блоки:

    -Картинка в хедере - не работает
    -Калькулятор - работает
    -FAQ - не работает

    Когда я подключаю в блок калькулятора не 1.4 а 1.8 или 1.9

    -Картинка в хедере - работает
    -Калькулятор - не работает
    -FAQ - не работает (не кликабельный (не открывает аккордеон)

    Когда я подключаю в блок калькулятора не 1.4 а 2.1

    -Картинка в хедере - работает
    -Калькулятор - не работает
    -FAQ - работает

    Я запутался :( Помогите пожалуйста разобраться
     
  2. searchingman

    searchingman Местный

    Сообщения:
    1.634
    Симпатии:
    553
    Баллы:
    113
    Скрипт калькулятора не адаптирован под последние версии jQuery.
    Ищите другой калькулятор или просите автора его доработать.
     
  3. Ria

    Ria

    Сообщения:
    52
    Симпатии:
    0
    Баллы:
    6
    Подскажите пожалуйста, как узнать какая версия jquery в плагине HTML5 Responsive FAQ. Я уже штук 10 калькуляторов разных переставил на сайт, все равно ошибки выдает и Responsive FAQ перестает работать
     
  4. searchingman

    searchingman Местный

    Сообщения:
    1.634
    Симпатии:
    553
    Баллы:
    113
    На странице плагина смотрите с какой версией Wordpress он совместим.
    Смотрите в нужной версии Wordpress версию библиотеки jQuery, н-р, версия jQuery для WP 4.6.1 ( jQuery v1.12.4)