• Вопрос без рабочей ссылки на проблему считается риторическим. Без ссылки и скриншота - провокацией!
  • Темы озаглавленные с маленькой буквы или капсом удаляются без предупреждения!

Решено Вывод атрибутов при импорте товара плагином WP All Import

dim70

Опытный
#1
Добрый день. Не получается решить проблему, которая проявилась при импорте товара. Для импорта использую плагин WP All Import. Создаю около 20 позиций атрибутов для простых товаров: upload_2017-9-16_9-49-49.png
запускаю импорт. В итоге получаю, что в карточке товара атрибуты прописались:
upload_2017-9-16_9-54-32.png
а вот общих атрибутов, которые потом нужны будут для создания фильтров - пусто.
upload_2017-9-16_9-56-11.png

В чём может быть причина?
 

Navigator1974

Форумчанин
#3
В низу поставь галочку!!
Добрый день. Не получается решить проблему, которая проявилась при импорте товара. Для импорта использую плагин WP All Import. Создаю около 20 позиций атрибутов для простых товаров: Посмотреть вложение 3436
запускаю импорт. В итоге получаю, что в карточке товара атрибуты прописались:
Посмотреть вложение 3437
а вот общих атрибутов, которые потом нужны будут для создания фильтров - пусто.
Посмотреть вложение 3438

В чём может быть причина?
1.У тебя простой товар тогда не надо галочки на вариайиях
2. Поставь галочку " Auto-Create Terms "
и все, 2017-09-16_191338.jpg 2017-09-16_191338.jpg
 

dim70

Опытный
#4

dim70

Опытный
#6
Я рад искрене что получилось, удачи... я вот сейчас тоже буду вопросы задавать , может мне кто поможет!!!
Я так обрадовался, что стали создаваться атрибуты, что упустил из вида такой момент. Убрав и установив галочки как на картинке:
upload_2017-9-16_23-33-17.png
я получил в карточке товара создание ссылок, которые мне не нужны, и которые почему-то ведут на страницу которой нет
upload_2017-9-16_23-35-14.png
если же галочку не ставить на "Is Taxonomy" то пункт "Auto-Create Terms" - пропадает, а при одном выбранном пункте "Is Visible" атрибуты не добавляются в общие атрибуты, а только на страницу товара. Что Вы посоветуете, чтобы и атрибуты добавлялись в общие атрибуты и ссылок не было (или хотя бы что они вели на какую-то существующую страницу)?
 

dim70

Опытный
#7
или хотя бы что они вели на какую-то существующую страницу
сделал изменения в разделе "постоянные ссылки"
upload_2017-9-16_23-51-54.png
и теперь ссылки ведут на страницу где собраны все товары относящиеся к выбранному атрибуту. В принципе можно и так будет оставить...
 

Navigator1974

Форумчанин
#10
Ссылки верни к дефолту там не надо ничего, и ещё важно, у тебя тоары то простые правильно или вариативные все таки?
 

Navigator1974

Форумчанин
#11
мой скайп kupi-tovary вечером по новосибирску, я сам сейчас в затыке, сам разместил о помощи и хрен кто поможет тут одни бля умники собрались....
 

Navigator1974

Форумчанин
#15
вам, после всех ваших душевных криков....
Да нет, я в 98 году завязал , я тож с дальнего востока с Камчатки кстати, кап 3, ВСГ , кил 168 , ты же с Владика вроде,я сейчас в Новосибе живу, нет ну правда впросто бывает такая анамалия что бошку сломаеш!! год назат перевел магазы на вукомерс а до этого на персте были... Сейчас проблема и никто не может помочь, думаю надо скрипты делать на уровне вукомерса.... Думаю опять на престашоп все перевести но потом попозже...
 

tuxfighter

Гуру
Местный
#18
А ты хорошо вордпрес и вукомерс знаеш?
немного знаю......
знаеш, есть такая старая притча: слушальнитца двухнедельных курсов английского языка в резюме пишет: "знаю язык в совершенстве", а выпускница филологигического факультета со спелизацией "английская филология" в резюме пишет: "немного знаю язык"
 

djjoid

Новичок
#19
Здравствуйте, а если товар уже есть, как к нему добавить атрибуты? Как тут описано не получается, атрибуты вообще не импортируются
 

Вложения

Marfius

Новичок
#20
Всем привет. У меня такая проблема: импортирую товары плагином wp all import, при настройке импорта отмечаю пункт настройки атрибутов "Is Visible" и при импорте в карточках товаров проставляются нужные атрибуты, к примеру, для каждого товара свой бренд.

INVISIBLE.png

После того, как добавляю пункты "Is Taxonomy" и "Auto-Create Terms", чтобы параметр атрибута стал активной ссылкой и вел на страницу где собраны все товары относящиеся к выбранному атрибуту при импорте в карточках товаров проставляется один и тот же атрибут для всех товаров. К примеру, один бренд для всех товаров.

INVISIBLE23.png

Может кто подскажет в чем проблема?
 
Сверху Снизу